$re = '/<td>(?:<a.*?>)?([^<]+)/';
$str = '<irrelevant things>
<tr id="myid">
<td>Content</td>
</tr>
<irrelevant things again>
<irrelevant things>
<tr id="myid">
<td><a href="somewhere.com">Content</a></td>
</tr>
<irrelevant things again>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);