// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<td>(?:<a.*?>)?([^<]+)").unwrap();
let string = "<irrelevant things>
<tr id=\"myid\">
<td>Content</td>
</tr>
<irrelevant things again>
<irrelevant things>
<tr id=\"myid\">
<td><a href=\"somewhere.com\">Content</a></td>
</tr>
<irrelevant things again>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}