using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td>(?:<a.*?>)?([^<]+)";
string input = @"<irrelevant things>
<tr id=""myid"">
<td>Content</td>
</tr>
<irrelevant things again>
<irrelevant things>
<tr id=""myid"">
<td><a href=""somewhere.com"">Content</a></td>
</tr>
<irrelevant things again>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}