import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td>(?:<a.*?>)?([^<]+)";
final String string = "<irrelevant things> \n"
+ " <tr id=\"myid\"> \n"
+ " <td>Content</td> \n"
+ " </tr> \n"
+ "<irrelevant things again>\n\n"
+ "<irrelevant things> \n"
+ " <tr id=\"myid\"> \n"
+ " <td><a href=\"somewhere.com\">Content</a></td> \n"
+ " </tr> \n"
+ "<irrelevant things again>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}