import re
regex = re.compile(r"<td>(?:<a.*?>)?([^<]+)")
test_str = ("<irrelevant things> \n"
" <tr id=\"myid\"> \n"
" <td>Content</td> \n"
" </tr> \n"
"<irrelevant things again>\n\n"
"<irrelevant things> \n"
" <tr id=\"myid\"> \n"
" <td><a href=\"somewhere.com\">Content</a></td> \n"
" </tr> \n"
"<irrelevant things again>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")