#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0-1:24.2.1\(160334278652W\))\((\d+\.\d+)(?:\*m3\))"
Local $sString = "0-1:24.2.1(160334278652W)(00033.596*m3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")