use strict;
my $str = '0-1:24.2.1(160334278652W)(00033.596*m3)';
my $regex = qr/^(?:0-1:24.2.1\(160334278652W\))\((\d+\.\d+)(?:\*m3\))/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}