using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0-1:24.2.1\(160334278652W\))\((\d+\.\d+)(?:\*m3\))";
string input = @"0-1:24.2.1(160334278652W)(00033.596*m3)";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}