// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0-1:24.2.1\(160334278652W\))\((\d+\.\d+)(?:\*m3\))").unwrap();
let string = "0-1:24.2.1(160334278652W)(00033.596*m3)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}