$re = '/^(?:0-1:24.2.1\(160334278652W\))\((\d+\.\d+)(?:\*m3\))/m';
$str = '0-1:24.2.1(160334278652W)(00033.596*m3)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);