const regex = /^(?:0-1:24.2.1\(160334278652W\))\((\d+\.\d+)(?:\*m3\))/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0-1:24.2.1\\(160334278652W\\))\\((\\d+\\.\\d+)(?:\\*m3\\))', 'm')
const str = `0-1:24.2.1(160334278652W)(00033.596*m3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}