#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+(null)(?!.*\befficient.*)"
Local $sString = "nullPANIFICACAO TOCANTINS LTDA" & @CRLF & _
"RELACAO DAS VENDAS POR CLIENTE PERIODO DE 31/05/2020 A 30/06/2020" & @CRLF & _
"Cod: 000004 Rota : 032 Nome : MULTI FORMATO DISTRIBUIDORA S/A" & @CRLF & _
"N.Fantasia : SUPER NOSSO Pro.:CONTATO" & @CRLF & _
"Endereco : RUA ANDRE CAVALCANTI 237 GUTIERREZ" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")