re = /^.+(null)(?!.*\befficient.*)/m
str = 'nullPANIFICACAO TOCANTINS LTDA
RELACAO DAS VENDAS POR CLIENTE PERIODO DE 31/05/2020 A 30/06/2020
Cod: 000004 Rota : 032 Nome : MULTI FORMATO DISTRIBUIDORA S/A
N.Fantasia : SUPER NOSSO Pro.:CONTATO
Endereco : RUA ANDRE CAVALCANTI 237 GUTIERREZ
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end