# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+(null)(?!.*\befficient.*)"
test_str = ("nullPANIFICACAO TOCANTINS LTDA\n"
"RELACAO DAS VENDAS POR CLIENTE PERIODO DE 31/05/2020 A 30/06/2020\n"
"Cod: 000004 Rota : 032 Nome : MULTI FORMATO DISTRIBUIDORA S/A\n"
"N.Fantasia : SUPER NOSSO Pro.:CONTATO\n"
"Endereco : RUA ANDRE CAVALCANTI 237 GUTIERREZ\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.