use strict;
my $str = 'nullPANIFICACAO TOCANTINS LTDA
RELACAO DAS VENDAS POR CLIENTE PERIODO DE 31/05/2020 A 30/06/2020
Cod: 000004 Rota : 032 Nome : MULTI FORMATO DISTRIBUIDORA S/A
N.Fantasia : SUPER NOSSO Pro.:CONTATO
Endereco : RUA ANDRE CAVALCANTI 237 GUTIERREZ
';
my $regex = qr/^.+(null)(?!.*\befficient.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}