import Foundation
let pattern = #"^.+(null)(?!.*\befficient.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
nullPANIFICACAO TOCANTINS LTDA
RELACAO DAS VENDAS POR CLIENTE PERIODO DE 31/05/2020 A 30/06/2020
Cod: 000004 Rota : 032 Nome : MULTI FORMATO DISTRIBUIDORA S/A
N.Fantasia : SUPER NOSSO Pro.:CONTATO
Endereco : RUA ANDRE CAVALCANTI 237 GUTIERREZ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)