using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+(null)(?!.*\befficient.*)";
string input = @"nullPANIFICACAO TOCANTINS LTDA
RELACAO DAS VENDAS POR CLIENTE PERIODO DE 31/05/2020 A 30/06/2020
Cod: 000004 Rota : 032 Nome : MULTI FORMATO DISTRIBUIDORA S/A
N.Fantasia : SUPER NOSSO Pro.:CONTATO
Endereco : RUA ANDRE CAVALCANTI 237 GUTIERREZ
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}