using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z]{5}.\d{4}";
string input = @"Identified Outlier
AOJan.2002 0.346
AOJun.2002 0.58979
AAFeb.2002 0.58972";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}