const regex = /[A-Za-z]{5}.\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z]{5}.\\d{4}', 'gm')
const str = `Identified Outlier
AOJan.2002 0.346
AOJun.2002 0.58979
AAFeb.2002 0.58972`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}