import re
regex = re.compile(r"[A-Za-z]{5}.\d{4}", flags=re.MULTILINE)
test_str = ("Identified Outlier\n"
"AOJan.2002 0.346\n"
"AOJun.2002 0.58979\n"
"AAFeb.2002 0.58972")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")