re = /[A-Za-z]{5}.\d{4}/m
str = 'Identified Outlier
AOJan.2002 0.346
AOJun.2002 0.58979
AAFeb.2002 0.58972'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end