// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b(?:you|u) only live once\b").unwrap();
let string = "- I'm not so sure about this tattoo, what if I regret it later?
- You only live once bro.
- Man, all this jumping out of buildings business is taking a toll on my body. Besides, it's pretty dangerous!
- Bro, you only live once!";
let substitution = "YOLO";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}