import Foundation
let pattern = #"\b(?:you|u) only live once\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
- I'm not so sure about this tattoo, what if I regret it later?
- You only live once bro.
- Man, all this jumping out of buildings business is taking a toll on my body. Besides, it's pretty dangerous!
- Bro, you only live once!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"YOLO"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)