# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([0-9]+)([0-9]+)([0-9]+)([0-9]+)-([a-zA-Z0-9_\-\/.]+)\/[a-zA-Z0-9_\-\/.]+$/http:\/\/blitz.example.com.s3-ap-southeast-1.amazonaws.com\/img\/p\/$1\/$2\/$3\/$4\/$1$2$3$4-$5.jpg/mg;t' <<< "3478-product_list_default/green-army-combats-type-i.jpg
3478-product_list_default/green-army-combats-type-i.jpg"