// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]+)([0-9]+)([0-9]+)([0-9]+)-([a-zA-Z0-9_\-/.]+)/[a-zA-Z0-9_\-/.]+$").unwrap();
let string = "3478-product_list_default/green-army-combats-type-i.jpg
3478-product_list_default/green-army-combats-type-i.jpg";
let substitution = "http://blitz.example.com.s3-ap-southeast-1.amazonaws.com/img/p/$1/$2/$3/$4/$1$2$3$4-$5.jpg";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}