package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]+)([0-9]+)([0-9]+)([0-9]+)-([a-zA-Z0-9_\-/.]+)/[a-zA-Z0-9_\-/.]+$`)
var str = `3478-product_list_default/green-army-combats-type-i.jpg
3478-product_list_default/green-army-combats-type-i.jpg`
var substitution = "http://blitz.example.com.s3-ap-southeast-1.amazonaws.com/img/p/$1/$2/$3/$4/$1$2$3$4-$5.jpg"
fmt.Println(re.ReplaceAllString(str, substitution))
}