import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]+)([0-9]+)([0-9]+)([0-9]+)-([a-zA-Z0-9_\\-/.]+)/[a-zA-Z0-9_\\-/.]+$";
final String string = "3478-product_list_default/green-army-combats-type-i.jpg\n"
+ "3478-product_list_default/green-army-combats-type-i.jpg";
final String subst = "http://blitz.example.com.s3-ap-southeast-1.amazonaws.com/img/p/$1/$2/$3/$4/$1$2$3$4-$5.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}