use strict;
my $str = '3478-product_list_default/green-army-combats-type-i.jpg
3478-product_list_default/green-army-combats-type-i.jpg';
my $regex = qr~^([0-9]+)([0-9]+)([0-9]+)([0-9]+)-([a-zA-Z0-9_\-/.]+)/[a-zA-Z0-9_\-/.]+$~mp;
my $subst = 'http://blitz.example.com.s3-ap-southeast-1.amazonaws.com/img/p/$1/$2/$3/$4/$1$2$3$4-$5.jpg';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";