#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([0-9]+)([0-9]+)([0-9]+)([0-9]+)-([a-zA-Z0-9_\-/.]+)/[a-zA-Z0-9_\-/.]+$"
Local $sString = "3478-product_list_default/green-army-combats-type-i.jpg" & @CRLF & _
"3478-product_list_default/green-army-combats-type-i.jpg"
Local $sSubst = "http://blitz.example.com.s3-ap-southeast-1.amazonaws.com/img/p/$1/$2/$3/$4/$1$2$3$4-$5.jpg"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)