#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([a-zA-Z0-9])*(\s|_)(__IMG__\d{4}_\d{2}_\d{2}__\d{2}_\d{2}_\d{2}_\d{3}|PXL_\d{8}_\d{9})(\.capture|heic|jpg])"
Local $sString = "abcde PXL_20230711_210613237.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")