// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([a-zA-Z0-9])*(\s|_)(__IMG__\d{4}_\d{2}_\d{2}__\d{2}_\d{2}_\d{2}_\d{3}|PXL_\d{8}_\d{9})(\.capture|heic|jpg])").unwrap();
let string = "abcde PXL_20230711_210613237.jpg";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}