use strict;
my $str = 'abcde PXL_20230711_210613237.jpg';
my $regex = qr/^([a-zA-Z0-9])*(\s|_)(__IMG__\d{4}_\d{2}_\d{2}__\d{2}_\d{2}_\d{2}_\d{3}|PXL_\d{8}_\d{9})(\.capture|heic|jpg])/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}