package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-zA-Z0-9])*(\s|_)(__IMG__\d{4}_\d{2}_\d{2}__\d{2}_\d{2}_\d{2}_\d{3}|PXL_\d{8}_\d{9})(\.capture|heic|jpg])`)
var str = `abcde PXL_20230711_210613237.jpg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}