re = /^([a-zA-Z0-9])*(\s|_)(__IMG__\d{4}_\d{2}_\d{2}__\d{2}_\d{2}_\d{2}_\d{3}|PXL_\d{8}_\d{9})(\.capture|heic|jpg])/
str = 'abcde PXL_20230711_210613237.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end