# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{5}(\d{4})(\d{2})(\d{2})/$1 $2 $3/;t' <<< "0000020140101"