// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{5}(\d{4})(\d{2})(\d{2})").unwrap();
let string = "0000020140101";
let substitution = "$1 $2 $3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}