re = /\d{5}(\d{4})(\d{2})(\d{2})/
str = '0000020140101'
subst = '$1 $2 $3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result