use strict;
my $str = '0000020140101';
my $regex = qr/\d{5}(\d{4})(\d{2})(\d{2})/p;
my $subst = '$1 $2 $3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";