#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)<img(?>[^>]* alt="([^"]+)")?[^>]*>"
Local $sString = "Schau mal: <img src="./dir/file.png" id="f" alt="flying dogs">" & @CRLF & _
"Magst Du <img src="./dir/file2.jpg" class="favorites" title="Schoki bis zum Abwinken" />?"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)