import Foundation
let pattern = #"(?is)<img(?>[^>]* alt="([^"]+)")?[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Schau mal: <img src="./dir/file.png" id="f" alt="flying dogs">
Magst Du <img src="./dir/file2.jpg" class="favorites" title="Schoki bis zum Abwinken" />?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)