using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)<img(?>[^>]* alt=""([^""]+)"")?[^>]*>";
string substitution = @"$1";
string input = @"Schau mal: <img src=""./dir/file.png"" id=""f"" alt=""flying dogs"">
Magst Du <img src=""./dir/file2.jpg"" class=""favorites"" title=""Schoki bis zum Abwinken"" />?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}