$re = '/(?is)<img(?>[^>]* alt="([^"]+)")?[^>]*>/';
$str = 'Schau mal: <img src="./dir/file.png" id="f" alt="flying dogs">
Magst Du <img src="./dir/file2.jpg" class="favorites" title="Schoki bis zum Abwinken" />?';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;