const regex = /(?is)<img(?>[^>]* alt="([^"]+)")?[^>]*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?is)<img(?>[^>]* alt="([^"]+)")?[^>]*>', 'g')
const str = `Schau mal: <img src="./dir/file.png" id="f" alt="flying dogs">
Magst Du <img src="./dir/file2.jpg" class="favorites" title="Schoki bis zum Abwinken" />?`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);