import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)<img(?>[^>]* alt=\"([^\"]+)\")?[^>]*>";
final String string = "Schau mal: <img src=\"./dir/file.png\" id=\"f\" alt=\"flying dogs\">\n"
+ "Magst Du <img src=\"./dir/file2.jpg\" class=\"favorites\" title=\"Schoki bis zum Abwinken\" />?";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}