using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s+|^)\S*(?<!\w)(?:https?|<filter>)(?!\w)\S*";
string input = @" hello, my name is James.
John 30 hello, my name is John. Here is my favourite website https://stackoverflow.com
Jim 27 Hi! I'm another persoon whose name begins with a J! Here is something that should be filtered out: <filter>
Do not filter anything when <filter or word<filter>word is present";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}