re = /(?:\s+|^)\S*(?<!\w)(?:https?|<filter>)(?!\w)\S*/
str = ' hello, my name is James.
John 30 hello, my name is John. Here is my favourite website https://stackoverflow.com
Jim 27 Hi! I\'m another persoon whose name begins with a J! Here is something that should be filtered out: <filter>
Do not filter anything when <filter or word<filter>word is present'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end