import re
regex = re.compile(r"(?:\s+|^)\S*(?<!\w)(?:https?|<filter>)(?!\w)\S*")
test_str = (" hello, my name is James. \n"
"John 30 hello, my name is John. Here is my favourite website https://stackoverflow.com\n"
"Jim 27 Hi! I'm another persoon whose name begins with a J! Here is something that should be filtered out: <filter>\n"
"Do not filter anything when <filter or word<filter>word is present")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")