import Foundation
let pattern = #"(?:\s+|^)\S*(?<!\w)(?:https?|<filter>)(?!\w)\S*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello, my name is James.
John 30 hello, my name is John. Here is my favourite website https://stackoverflow.com
Jim 27 Hi! I'm another persoon whose name begins with a J! Here is something that should be filtered out: <filter>
Do not filter anything when <filter or word<filter>word is present
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)