use strict;
my $str = ' hello, my name is James.
John 30 hello, my name is John. Here is my favourite website https://stackoverflow.com
Jim 27 Hi! I\'m another persoon whose name begins with a J! Here is something that should be filtered out: <filter>
Do not filter anything when <filter or word<filter>word is present';
my $regex = qr/(?:\s+|^)\S*(?<!\w)(?:https?|<filter>)(?!\w)\S*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}