# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^a-zA-Z\n]+|[^a-zA-Z\n]+$|[^a-zA-Z\s]+//gm;t' <<< "Hi, you!
No under_score!
* rem punct then spaces "